Page tree
Skip to end of metadata
Go to start of metadata

PHP 7

PHP 7 is supported for Blesta 4.0.0 and higher.

Special Requirements

Every effort is made to stay within the below requirements for the extensions that ship with Blesta. Certain extensions (plugins, modules, and gateways) that ship with Blesta, or which are available through the Marketplace however, may have their own unique requirements. In many cases, recommended requirements include PHP extensions that make additional features available, or improve the performance of certain features.

MySQL 5.7+

MySQL changed the default behavior in version 5.7.5 to enable "only_full_group_by". If you are using a version newer than that, or if you had changed your MySQL configuration file to enable "only_full_group_by", you will need to remove it. You should update your MySQL configuration file to disable "sql_mode", i.e., don't have it set to "only_full_group_by". You can run the following query to determine what the sql_mode is: SELECT @@GLOBAL.sql_mode, @@SESSION.sql_mode;

System Requirements

Minimum Requirements
  1. PHP version 5.4
  2. PDO, pdo_mysqlcurl (version 7.10.5), and openssl (version 0.9.6) PHP extensions
  3. MySQL version 5.0.17
  4. Apache, IIS, or LiteSpeed Web Server
  5. ionCube PHP loader
Recommended Requirements

 The following requirements are recommended, and if met will provide a better experience and more full use of available features. 

  1. PHP version 7.2 or later
  2. PDO, pdo_mysql, curl (version 7.10.5 or later), openssl (version 1.1.1a or later), gmp, imap, json, ldap, libxml, mailparse, iconv, mbstringmcrypt (PHP <7.2), simplexml, and zlib PHP extensions
  3. MariaDB version 10.2 or later with max_allowed_packet = 128M or higher, and wait_timeout = 3600
  4. Apache, IIS, or LiteSpeed Web Server
  5. ionCube PHP loader
  6. memory_limit set to 128 MB or greater
  • No labels