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@ The Domain Manager is installed by default, but may need to be installed for addon companies, or those upgrading from a version earlier than
5.1.

About Domain Manager

The Domain Manager is responsible for handling the registration, renewal and provisioning of domains, as well as managing the pricing and packages.
Tie-Ins*

Widgets Nav Links Client Cards Automation Tasks Email Templates ACL Permissions Search

* Plugins are powerful and are not limited to the tie-ins listed above, these are just some of the most common

Installing Domain Manager

1. Visit [Settings] > [Company] > [Plugins] > Available.
2. Click the "Install" button within the Domain Manager plugin listing.

Domain Manager (ver 1.0.0)
.. bleSta @D author: Phillips Data, Inc. m
o g Used to handle various aspects of domain management and sales

Managing TLDs

Domain Manager Overview
Once installed, a new menu item will appear under Packages called [Domain Options], where TLDs pricing and other options can be managed, and an

option under Billing called [Domains] where all domains are listed and can be managed, similar to services. In the screen below, three TLDs have already
been created and they can be managed at this location.

Domain Manager - TLD Pricing

+ Add TLD
TLD DNS Management Email Forwarding 1D Protection EPP Code Module Options
X .com Mone a Edit, Enable
X .net Mone a Edit, Enable
X org Mone a Edit, Enable

Adding anew TLD

To add a new TLD navigate to [Packages] > [Domain Options] > [TLD Pricing] and click the "Add TLD" button in the upper right. By default the TLDs are
added without any pricing and disabled, to modify the TLD prices click on the "Edit" link, which will open the TLD settings modal.

x -- Please Select -- a Add

The TLD configuration modal contains several tabs, which are as follows:

® Pricing

® Name Servers
®* Welcome Email
®* Advanced

Updating the Pricing of a TLD

This tab allows to change the prices for this TLD in all of the currencies that the company has installed, as well as assign different prices for Registration,
Renewal, and Transfer for periods from one to ten years. TLDs are created by default with a $0 cost for each currency; as a result, the TLD is created
disabled to avoid accidentally offering it for free, you will need to manually activate the TLD after modifying the price for the very first time.



Update TLD .com
Pricing Name Servers Welcome Email Advanced
EUR AUD CLP GBP INR JPY uso
Term Register Price Renew Price Transfer Price
1 year 10.0000 15.0000 15.0000
2 year 20.0000 30.0000 30.0000
3 year 0.0000 0.0000 0.0000
4 year 0.0000 0.0000 0.0000
5 year 0.0000 0.0000 0.0000
6 year 0.0000 0.0000 0.0000
7 year 0.0000 0.0000 0.0000
8 year 0.0000 0.0000 0.0000
9 year 0.0000 0.0000 0.0000
10 year 0.0000 0.0000 0.0000
Cancel

Updating the Name Servers of a TLD

This tab allows to specify the name servers (NS) that will be used for this TLD; these NS are passed directly to the registrar module, which is in charge of
updating the DNS accordingly. The NS defined here are usually available in the welcome email as tags. (The availability of this feature will depend on
whether the registrar module implements such functionality and may not be available for all TLDs or registrars.)

Update TLD .com

Pricing Name Servers Welcome Email Advanced
Nameservers
Name Server 1

ns1.blesta.com

Name Server 2

ns2.blesta.com

Name Server 3

ns3.blesta.com

Name Server 4

ns4.blesta.com|

Updating the Welcome Email of a TLD

Similar to the welcome email in the packages, this one contains information about the registered or transferred domain. If you are not sure or need help on
how to structure the email, you can load an example provided by the module by clicking on the "Load Sample Email" button. (The availability of this feature
will depend on whether the registrar module implements such functionality and may not be available for all TLDs or registrars.)



Update TLD .com

Pricing Name Servers Welcome Email Advanced

Welcome Email

Load Sample Email
Tags:

{client.id} {client.id_code} {client.first_name} {client.last_name} {pricing.term} {pricing.period} {pricing.currency} {pricing.price} {pricing.setup_fee} {pricing.cancel_fee}
{service.DomainName}

English, US
HTML Text
Paragraph v v Al g2 AvRA~v B I @ T, T~ 2"~ =~ iz i= —

Your new domain has been successfully registered!
Domain: {service.DomainName}
Thank you for your business!

Advanced Settings

This tab includes any additional settings that the registrar module defines as required for a specific TLD. If you need to define Client Limits, Configurable
Options, Availability, Integrations among other options, you can edit the core package for a specific TLD by clicking on the "Edit Package" button. All TLDs
created through the Domain Manager are normal packages internally and can be modified in the same way.

Update TLD .com

Pricing Name Servers Welcome Email Advanced
Maodule Options

Group
Any a
Account

blesta B

Type

Domain Registration B

Advanced Options

Edit the core package, to define Client Limits, Configurable Options, Available Quantity, Plugin Integrations, Descriptions and more.

Edit Package

Installing a Registrar Module
If you want to install registrar module provided with Blesta:

1. Visit [Domains] > [Registrars].



2. Click the "Install" button within the listing of the registrar you want to install.
If you want to install registrar module from a third-party provider:

1. Upload the registrar module to "/components/modules”.
2. Visit [Domains] > [Registrars].
3. Click the "Install" button within the listing of the registrar you want to install.

Domain Manager - Registrars

. Namecheap (ver 2.8.0)
\Nal'nEd]eap Author: Phillips Data, Inc VETSYTSl  Uninstall
Address

ife!
your ke Namecheap, Inc. is an ICANN-accredited domain name registrar, which provides domain name registration and web hosting. Namecheap is a
budget hesting provider with 11 million registered users and 10 million domains.

] . NameSilo Domains Module (ver 1.14.0)
s‘ 0 Author: Phillips Data Inc., KnownHost LLC, NETLINK IT SERVICES Manage Uninstall
damains. cheap, easy and secure. Resell domains through NameSilo.

Enom {ver 2.9.0)
Author: Phillips Data, Inc., Sponsored by 1383 Ltd {London, UK) Install
Enom, Inc. is a domain name registrar and Web hosting company that also sells other products closely tied to domain names, such as S5L
certificates, e-mail services, and Website building software.

LogicBoxes (ver 2.9.0)
Author: Phillips Data, Inc. Install
LogicBoxes is a domain registrar.

Updating the Registrar Module of a TLD
To update the registrar module of a TLD visit [Packages] > [Domain Options] > [TLD Pricing] and within the TLD listing, select in the Module dropdown the

new module you desire. Only TLDs that do not have any active services can be updated; if the TLD you want to update does have active services, you
must create a new TLD.

Domain Manager - TLD Pricing

+ Add TLD
TLD DNS Management Email Forwarding ID Protection EPP Code SaloEIs= Options
None
4 X .com + Namecheap > Edit, Enable
NameSilo Domains Module
X .net Edit, Enable

After updating the module of a TLD, Blesta will attempt to automatically map as many fields as possible but some fields may require a manual
update. When this occurs, a modal box will be opened with the fields that need to be updated manually.

Update Package Meta for TLD .net
Module Options

Group

Ay a

Type

Domain Registration B

Update

Managing Domains

The Domain Manager provides a centralized location where all domains registered with the company can be managed, under [Billing] > [Domains]

Domains



This section displays all domain services, including the registration and expiration dates, as well as whether or not auto-renewal is enabled.

Domain Manager - Browse Domains

Active (1) Pending (0) Suspended (0) Canceled (0) Scheduled (0) = In Review (0] T
Domain Client Registrar Price Repgistration Date « Expiration Date Auto Renewal Optians
blesta.com Paul Phillips (#1600) None €15.00 EUR 2021-05-14 20:09:28 2022-05-14 20:09:28 Yes Manage

Domains in this area can also be filtered, similar to standard services.

Registrar Modules TLD Domain Name

Any a

Submit

Request the WHOIS Information of a Domain or Check its Availability

The plugin allows from the Staff area to lookup for the WHOIS information of a domain as well as verify its status and availability. To obtain the information
of a domain, visit [Domains] > [Whois] and enter the domain to be queried in the "Domain" text field, and then click the "Lookup" button. Currently this
feature does not support all TLDs, to see a complete list of supported TLDs, please visit the following link.

Domain Manager - Whois Domain Lookup
Domain Lookup

Domain

blesta.com

Domain Unavailable

Domain Mame: blesta.com

Registry Domain ID: 1@@2678783_DOMAIN_COM-VRSN
Registrar WHOIS Server: WHOIS.ENOM.COM
Registrar URL: Www.ENOM.COM

Updated Date: 2020-04-87T22:01:42.00Z
Creation Date: 2007-05-30T16:35:27.00Z
Registrar Registration Expiration Date: 2025-05-30T16:35:00.00Z
Registrar: ENOM, INC.

Registrar IANA ID: 48

Domain Status: clientTransferProhibited https://www.icann.org/epp#clientTransferProhibited
Registrant Name: REDACTED FOR PRIVACY
Registrant Organization: REDACTED FOR PRIVACY
Registrant Street: REDACTED FOR PRIVACY
Registrant Street:

Registrant City: REDACTED FOR PRIVACY
Registrant State/Province: CA

Registrant Postal Code: REDACTED FOR PRIVACY
Registrant Country: US

Registrant Phone: REDACTED FOR PRIVACY
Registrant Phone Ext:

Registrant Fax: REDACTED FOR PRIVACY
Registrant Email: https://tieredaccess.com/contact/e310824f-boeb-4008-8edd—-fad195ccaddt
Admin Name: REDACTED FOR PRIVACY

Admin Organization: REDACTED FOR PRIVACY
Admin Street: REDACTED FOR PRIVACY

Admin Street:

Admin City: REDACTED FOR PRIVACY

Admin State/Province: REDACTED FOR PRIVACY
Admin Postal Code: REDACTED FOR PRIVACY

Admin Country: REDACTED FOR PRIVACY

Admin Phone: REDACTED FOR PRIVACY

Admin Phone Ext:

Admin Fax: REDACTED FOR PRIVACY

Admin Email: REDACTED FOR PRIVACY

Tech Name: REDACTED FOR PRIVACY

Plugin Configuration
The configuration are contains the following tabs:

® General

® Notifications

®* Advanced

® Import Packages

General

In this section you can choose the TLDs that will be featured, all other TLDs will be hidden in the order form and a "Show All" button will be displayed,
which will show the rest of the TLDs.


https://github.com/io-developer/php-whois/blob/master/src/Iodev/Whois/Configs/module.tld.servers.json

Configuration

General Notifications Advanced Import Packages

Spotlight TLDs

.com net Jorg

[# Update Configuration

Notifications

There are three types of notifications, which are based on ICANN specifications, which are:
® 1st Renewal Reminder
® 2nd Renewal Reminder

® Expiration Notice

Each notification has its own email template, which can be edited by clicking the "Edit Email Template" link.

Configuration
General Notifications Advanced Import Packages
1st Renewal Reminder Days Before
35 Days B

& Edit Email Template

2nd Renewal Reminder Days Befare

10 Days B

S Edit Email Template

Expiration Motice Days After

1Day B

& Edit Email Template

[# Update Configuration

Setting Default Description
Value
1st Renewal Reminder Days 35 Days The number of days before a domain expires to send the first renewal email (26-35 as per ICANN
Before specs).
2nd Renewal Reminder Days 10 Days The number of days before a domain expires to send the second renewal email (4-10 per ICANN
Before specs).
Expiration Notice Days After 1 Day The number of days after a domain expires to send the expiration notice email (1-5 per ICANN
specs).
Advanced

This area allows to modify the option groups for the features available to the TLDs. By default the plugin will automatically create and assign an option
group for each feature.



Configuration
General Notifications Advanced Import Packages

Taxes

Enable Tax for Domains

Package Options

DNS Management Option Group

DMS Management B

Email Forwarding Option Group

Email Forwarding B

ID Protection Option Group

ID Protection 8

EPP Code Option Group

EPP Code [2 ]
[# Update Configuration
Setting Default Value Description
Enable Tax for Domains Unchecked Whether or not the TLD Packages should be taxed.
TLD Package Group TLDs Pricing The package group to which all TLD packages will be assigned.
Packages
DNS Management Option DNS Management The configurable option group used to control whether a domain will have DNS management
Group services.*
Email Forwarding Option Email Forwarding The configurable option group used to control whether a domain will have email forwarding
Group services.*
ID Protection Option Group ID Protection The configurable option group used to control whether a domain will have ID protection
services.*
EPP Code Option Group EPP Code The configurable option group used to control whether a domain will have access to the EPP
Code.*

*The availability of this features will depend on whether the registrar module implements such functionality and may not be available for all TLDs or
registrars.

Import Packages

In this section you can import previously created packages that are using any of the registrar modules. If multiple packages are assigned to the same TLD,
then the domain manager will clone the first one it encounters and ignore the others. Only yearly pricings will be cloned. If a package has no yearly pricings
it will be skipped. Cloned packages will be deactivated if they have no services after import.



Configuration

General Motifications Advanced Import Packages

This tool will search for any packages that use a registrar module and clone the package once for each of the TLDs assigned to it. If multiple
packages are assigned to the same TLD, then the domain manager will clone the first one it encounters and ignore the others. Only yearly pricings
will be cloned. If a package has no yearly pricings it will be skipped. Cloned packages will be deactivated if they have no services after import.

Migrate Services ?

"] Overwrite TLD Packages ?

[# Import Packages
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